1
$\begingroup$

Both the syntax "\binom{n}{r}" and the syntax "{n \choose r}" produce the message "[Math Processing Error]" for me when I use this site (and also History of Science and Mathematics), but work fine when I use Math.SE or Mathoverflow. In case it matters, I am running Safari 9.0.2. Why would MathJax behave differently on some sites than on others? Incidentally, the syntax "\left(n\atop r\right)" produces correct output on all four sites.

$\endgroup$
11
  • $\begingroup$ I do not know what exactly is going on but similar things were in fact reported on MO, see this comment and this meta-question It may be that things are unstable at the moment. $\endgroup$
    – quid Mod
    Jan 9 '16 at 23:43
  • $\begingroup$ $\binom{n}{r}$ ${n \choose r}$ $\left(n\atop r\right)$ $\endgroup$ Jan 12 '16 at 3:57
  • $\begingroup$ All three commands currently work for me. (See my comment above.) $\endgroup$ Jan 12 '16 at 3:58
  • $\begingroup$ @JoelReyesNoche The first two of your expressions render as "[Math Processing Error]" for me. Right clicking gives the option to view the actual error, which is "Error: this.CHTMLcreateNode is not a function. (In 'this.CHTMLcreateNode(e)', 'this.CHTMLcreateNode' is undefined) file: cdn.mathjax.org/mathjax/latest/extensions/TeX/… line: 19" $\endgroup$ Jan 12 '16 at 7:20
  • $\begingroup$ @WillOrrick, the problem might be browser- or operating system-specific, then. I'm using Firefox on Windows. $\endgroup$ Jan 12 '16 at 12:28
  • 1
    $\begingroup$ Clearing the browser cache, as suggested in one of @quid's links, fixed it. My limited understanding is that clearing the cache forces MathJax to be reloaded. It's still not clear to me what's really going on behind the scenes--for example, why the cached version isn't automatically replaced when a site updates its version of MathJax. $\endgroup$ Jan 17 '16 at 11:24
  • $\begingroup$ Does it have to do with \usepackage{} commands that you are using in preambles of your document templates? If Matheducators.SE doesn't use those package functions when compiling the latex code, it will return an error. It makes sense that Math.SE and Mathoverflow enable additional packages than standard. Disclaimer: this is a wild guess. $\endgroup$
    – Andrew
    Jan 19 '16 at 18:29
  • $\begingroup$ @Andrew I've never knowingly used \usepackage{} commands on Stackexchange sites, and the posts that gave me trouble on this site didn't either, as far as I can tell. This post is an example. Since clearing my browser cache, everything works fine. My guess is that, although the current version of MathJax installed on this site is fine, there was a defective version of MathJax at some earlier time, and that version got stored in my cache (for this site, but not MathOverflow or Math.SE). quid's links suggest that a few... $\endgroup$ Jan 19 '16 at 18:42
  • $\begingroup$ ...other users also encountered these defective versions. This is only a guess, however, as I don't have a good idea about how things really work. $\endgroup$ Jan 19 '16 at 18:43
  • $\begingroup$ @WillOrrick I meant to suggest that since you don't have the option of importing packages in SE documents (do you?) you may be using functions associated with a non-standard package that won't work here. Since the problem resolved by clearing your cache, I suspect that that's not what was going on. $\endgroup$
    – Andrew
    Jan 19 '16 at 19:08
  • $\begingroup$ @Andrew: sorry, I misunderstood your comment. My original guess as to the cause of the problem was the same as yours, and, indeed, editing the offending post to use more generic TeX/LaTeX fixed the problem. All of the users who reviewed my edits, however, rejected them, which made me realize that they must not have been experiencing the same issues with rendering that I was. It seems that, because of caching, different users viewing a post at the same time can be using different versions of MathJax. It may be that some of these versions were importing the needed packages, while others weren't. $\endgroup$ Jan 19 '16 at 20:04

You must log in to answer this question.

Browse other questions tagged .